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Sketchup command list pdf file download

Kinda pointless to provide files that people can’t open. Thanks for jumping in. I’ve been away from SU for a while and just discovered that the “traditional” shortcut keys have been changed in SU '18. If you’d like to see a guide to all the built-in SketchUp keyboard shortcuts, sign up for my email list and you can download it for free. (Download links at
the bottom of help article, but be sure your SketchUp version is chosen in the droplist at the top right of the page.) Also at any time, you can open the Ruby Console (from the Window menu,) a get a listing of the current shortcuts (aka keyboard accelerators,) that are assigned. Then when the release version of v18 came out and I installed it, those
“temporary” shortcuts from the release version of v17 were automatically migrated to v18 and showed up when I started using the non-Beta version. Meme: G for: Group as component… Alt+G is for: Group as group. Then build on from there. Paste in Place allows you to copy or cut an object from one group/component, and paste it into another
without moving it from its physical location. Download the keyboard shortcut guides for free by creating a free MasterSketchUp account. Custom Keyboard Shortcuts In addition to the default keyboard shortcuts that I use, I have found the need over the years to add a few additional custom keyboard shortcuts as well. -Geo 4 Likes Ok. Thanks for that
feedback. To be able to toggle back and forth between this is super helpful, so I’ve assigned it to the letter X. dustydayz56: Kinda pointless to provide files that people can’t open. Experienced users tend to create shortcuts to suit their individual workflow. I looked on the Knowledge Center but did not find an official list from Sketchup team. Default
Keyboard Shortcuts SketchUp has a number of keyboard shortcuts configured by default. SketchUp already has the letter G assigned to make a component from the selected entities, so it only seemed right to create a custom shortcut using SHIFT + G to make a group. If you have any extra faces or edges “inside” the model, they need to be deleted.
You can also add your own, custom keyboard shortcuts by going to Window -> Preferences -> Shortcuts. But I remember it because the letter Q is round, and has a “handle” on it. But sometimes I have everything in one screen if I need to have the other monitor occupied by a PDF, or something. SketchUp has a great feature built in called Hide Rest
of Model, and what that does is it hides anything outside of the current groups or component that you’re editing. They are a tremendous time saver, enabling you to get your ideas modeled more quickly. for “keyboard shortcuts”. In any case, it’s definitely “operator error” in not remembering that I had made that change “temporarily”. I just didn’t
want to go my own route and then find out later there was an entire extended set that most people try to use. This is silly, but the way I remember the shortcuts is N stands for “NO! I don’t want to see this object right now.” And J stands for “Just Joking… You can be visible now…” It also helps that the letters are right next to each other. You might
find these handy: PrintKeys.rb by Jim Foltz creates a printable list of your shortcuts. Then you could use the rbz files that you referenced. Are there any commonly used kb shortcuts that people tend to use for those functions that are not already assigned by Trimble (default)? If things are getting cluttered and I need to be able to see my model, I just
hit CTRL D to hide all the windows, and when I need the windows back, I hit CTRL D once again. That worked. So you could grab the handle and rotate it around
) E – Eraser tool G – Make Component (See below, I created a custom shortcut SHIFT + G to make group) Arrow keys – Lock axis Watch the video below to see how fast keyboard
shortcuts are, as well as my 6 custom keyboard shortcuts. Subscribe to my YouTube Channel I pretty much always use exact dimensions, so I’m always typing numbers to define measurements as well. printkeys.rbz (889 Bytes) And there’s ShortCutsV2.rb which Thomas (tt_su) fixed for us a while back. What’s important is their shortcuts suit their
individual needs and preferences. SketchUp has a built-in command that hides all open windows temporarily. 1 Like F1 may well be hard-coded on Windows. 1 Like Hi August, That seems like a good and likely explanation. -Geo 3 Likes Hello Brian… From Sketchup: “G” is “Make component” ( in right click menu) I made “Alt + G” into "Make group.
Use this Ruby one-liner: puts Sketchup::get_shortcuts If you want a hash to lookup: kb = Hash[Sketchup::get_shortcuts.map{|s| s.split("\t")}] then you can pretty print it: require("pp") pp kb 10 Likes Very nice. maybe others will chime in with their most useful commands and related shortcuts and make this thread a really great resource! A couple of
standard changes I make to the default shortcuts are: Change the default F for Offset tool to O. At least, I think that’s how it happened. Paste in Place SHIFT + V = Paste in Place Paste in place is a really useful action built into SketchUp, that is not very well known. Ergonomics (for Right handers): Put as many shortcuts, as possible, near the left side
of keyboard Memes: Remember shortcuts in “pictures or memes”… My example: “W” is “Wipe” for hide(wipe) rest of model… (toggle) and “Alt + W” is Hide(wipe) similar… (toggle) Make 2 lists of your shortcuts…(excel) 1 sorted by Name: (what did I choose for “Top View”) and 1 is sorted by Shortcuts: (what does “F8” do?) Both have the full path, as
extra column: "Camera/Standard Views /Top" I even made a “keyboard” in Excel…to “See” where stuff is.(3D memory). (Meme: “Alt” is “Alternative”) I collect shortcuts… from people I follow on You Tube…“Sketchup School” for example. F1 still brings up Help and P should still be for Push/Pull. When you Paste in Place, the copy will appear at the
same exact coordinates and orientation as the original. Creating groups SHIFT + G = Create group from selected One of the most common things you do in SketchUp is turn things into groups and components. I forgot about the quick reference cards. 5 Likes I recently came across this site with a pretty good list of SketchUp keyboard shortcuts and I
now use it all the time. Based on what you wrote in your profile, you need to be using SketchUp Pro anyway. At that point what is default and what is user defined rapidly becomes blurred and irrelevant. Is there a list of the changes available anywhere? Modeling becomes more fluid and natural. next page → Then, select the command you’d like to
create a shortcut to. briankb: Is there a complete list of the Keyboard Shortcuts that a defined by Default? I use the letter N to hide selected, and the letter J to unhide last. The Quick Reference Card lists many of them. True, “O” is preassigned to the Orbit tool, but if you use a three-button mouse you never need to use the Orbit tool anyway. Then I
spent some months where I was doing all my SU on the v18 beta, so of course that was a parallel, vanilla installation and didn’t have those shortcut changes. You can look at the Quick Reference card to get an idea of the keyboard shortcuts. Then, in a classic case of “Where’s my … HERE it is!”, after I stopped wrestling with it, and maybe after asking
for help, the answer came to me while lying in bed: I had been working on something where I had been trying to do a kind of free-form follow-me, moving a surface with push/pull without a path, and I had “temporarily” changed the two tools I was using alternately, Rotate and Push/pull, to be under F2 and F1. shortcutsV2.rbz (237 Bytes)
Nonetheless, SU’s default shortcuts are merely a starting point for new users. The one I have is from various authors and is as follows: Select (Spacebar) Paint Bucket Rectangle Circle Move Rotate (Q) Scale Tape Measure Orbit Zoom Eraser Line Arc Push/Pull Offset Zoom Extends (Shift-Z) Before I go all crazy and assign other tools to specific keys I
was curious if there was an extended list of Keyboard Shortcuts that people are already trying to use or make global for the application. In this article, I highlight the keyboard shortcuts I use most often, and demonstrate how helpful they are in saving time while modeling. I thought F1 was a Windows hard-coded shortcut and would have expected
that one to revert to Help since it is the standard Help shortcut for most programs. When you find yourself repeating a command via the menus it’s a signal to assign a shortcut. Oh well, it sounds like you’ve got it sorted out. For instance, when creating a model for 3D printing, it needs to be solid. Below are some of my most frequently used keyboard

shortcuts. By tapping the designated key, you’ll activate that tool without having to select it from a menu or toolbar. I also use a shortcut to turn Hidden Geometry on and off: Alt-G (my mnemonic is "alternate graphics). briankb: Are there any commonly used kb shortcuts that people tend to use for those functions that are not already assigned by
Trimble (default)? You can also download my custom keyboard shortcuts at the bottom of this article, and import them into your SketchUp. I have always been a strong advocate for using keyboard shortcuts. Keep in mind it’s the commands that are important, not the particular shortcut keys I assigned to them. slow and steady should win this race
though. How can you become faster at modeling? The post you are referring to was made over three years ago; well before SketchUp Free was even mentioned. Select the shortcuts file you downloaded and click ok. Once you’ve downloaded them, go to Window -> Preferences -> Shortcuts, and click Import. I finished my experiment, but I forgot to
put things back. Don’t be too concerned about what others choose to do. The arrow keys are also frequently used to lock axis any time I’m drawing a line, or moving an object. Where it says “Add Shortcut”, click in the text box then tap the key combination (or single letter) you want to use for the shortcut. I created some custom keyboard shortcut
guides for every version of SketchUp. Download them for free below. Thanks DaveR. CTRL + D = Hide Dialogs (toggle) One of the things I love about having dual monitors is that I can place all the popup windows in one screen, and have a full workspace in the other. The files @Geo posted are plugins to be used in SketchUp Make or SketchUp Pro.
SketchUp Is there a complete list of the Keyboard Shortcuts that a defined by Default? Set things up to suit your individual workflow. Sign up here, or login. Amazing what comes to us when we are almost asleep. Many people are intimidated with the idea of having to remember a ton of keyboard shortcuts, but I assure you, the majority of them are
obvious and easy to remember. -Geo 1 Like Those are good! I’ve been doing “Hide Rest of Model” using the Layers (photoshop style) extension because I didn’t realize this was a function. Ahh… I should have looked. This is really useful for when you are reviewing the organization of your model, and need to move things from one group/component to
another. Sometimes you can locate these extra entities by switching to Xray mode, but it tends to be a bit overwhelming when you can see all the edges in your model. If you are using SketchUp Free as indicated in your profile, the rbz files won’t help you out. You can get the Quick Reference card from the link Geo provided. I have it printed out and
on my desk somewhere. Start out with a few simple ones, like Select (Spacebar), Push/Pull (P), and Rectangle (R). “Golden rules” now, for me, is: Use the left hand…for logic operations… Let the right “mouse”-hand do the creative stuff. Nice to have the same shortcuts, when they demonstrate and you pause and try. One good idea, is, to “Swap” the
“Z” to: “Zoom Extents”… brings you “out”, If you get: “Lost” In Model"… Greetings for now, hope it is useful…Jakob. They reduce the friction between the design and the software. Spacebar – Select tool R – Rectangle tool L – Line tool M – Move tool P – Push/pull tool S – Scale tool Q – Rotate tool (This is one with a weird letter. Just be aware that that
importing these shortcuts will override any custom shortcuts you already have, so you might want to backup yours just in case. I think you must have an installation error. PS idea. I can’t test it as I’m on a Mac. To me, keyboard shortcuts for these two commands are essential to efficient modeling. To understand what Paste in Place does, you first
need to understand groups and components. Go to Preferences>Shortcuts and click on Reset to see if that fixes them. -Gully 6 Likes briankb: maybe others will chime in with their most useful commands and related shortcuts and make this thread a really great resource! Again, focus on what you do and don’t be too concerned about what others do. •
View > Component Edit > Hide Rest of Model • View > Component Edit > Hide Similar Components I assigned Ctrl+H and Alt+H respectively. Just saying… I am a novice when it comes to this sorta thing so any help you can provide would be appreciated. You can add your own custom keyboard shortcuts, or, if you like the one I use, you can
download my keyboard shortcuts and import them right into SketchUp. (Download link at end of tutorial.) To add a custom shortcut, go to Window -> Preferences -> Shortcuts. By temporarily hiding a face, I can quickly identify what needs to be deleted, then I can unhide the face when I’m done. Click the plus sign, and you’re done. Controlling what
you see at any given moment X = Hide Rest of Model One of the ways I’m able to increase my speed, and reduce frustration, is to have control over what objects I see in my model. @August, it’s good to see you back here. The power of SU is you play your own game. N = Hide Selected J = Unhide Last I’ve also found it useful to be able to temporarily
hide selected faces, and quickly unhide them. Once the F is freed up, I then assign it to Follow Me, which by default has no shortcut at all. This reminds me of the issue some user had when all icons were shifted 1 step. AFAIK there is no comprehensive list of the default keyboard shortcuts. For instance I would like to assign some shortcuts for the
Camera Views: Top, Side, Front, and ISO 2 Likes SketchUp Help : Quick reference card These are nice PDF cards that you can print out and paste near your workstation. Too bad it doesn’t show up when you do a search on help. Have most used shortcuts, as “One key”-single clicks…like Sketchup do My example: “X” for: “X.Ray On / Off”…(a toggle
function) Let 2 fingers of the left hand do the 2 key-button clicks: My example: Thumb on “Ctrl” + index on “A” for “Select All”. A few others I use: Alt-H for Hide, Alt-E for Erase Guidelines, Alt-P for Paste-in-Place. Just saying… Seriously? For instance, F1 is no longer Help, it’s now Push/Pull and the P key does nothing. I think most users would agree
that the ability to setup shortcuts just the way you want is one of SU’s most powerful and endearing qualities.
Overview of Polygon Cruncher a plugin for Autodesk 3ds Max, Maya or Lightwave and also available as a stand alone software (FBX, Sketchup, Cinema 4D, Modo...). Polygon Cruncher simplifies your 3D models (from game, architecture, design, CAD). Polygon Cruncher preserves textures (multi UVs), vertex painting (multi VCs), normals and
generates different LOD for your … Overview of Polygon Cruncher a plugin for Autodesk 3ds Max, Maya or Lightwave and also available as a stand alone software (FBX, Sketchup, Cinema 4D, Modo...). Polygon Cruncher simplifies your 3D models (from game, architecture, design, CAD). Polygon Cruncher preserves textures (multi UVs), vertex
painting (multi VCs), normals and generates different LOD for your …
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